Aller au contenu
7.1 Élevée

CVE-2024-55633 Improper Authorization vulnerability in Apache Superset

Description

Improper Authorization vulnerability in Apache Superset. On Postgres analytic databases an attacker with SQLLab access can craft a specially designed SQL DML statement that is Incorrectly identified as a read-only query, enabling its execution. Non postgres analytics database connections and postgres analytics database connections set with a readonly user (advised) are not vulnerable.  This issue affects Apache Superset: before 4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Superset 4.1 premières → < 4.1.0 4.1.0

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 65 CVE de Apache Superset →
Suivre cette CVE