Aller au contenu
9.1 Critique

CVE-2024-4442 The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and…

Description

The Salon booking system plugin for WordPress is vulnerable to arbitrary file deletion in all versions up to, and including, 9.8. This is due to the plugin not properly validating the path of an uploaded file prior to deleting it. This makes it possible for unauthenticated attackers to delete arbitrary files, including the wp-config.php file, which can make site takeover and remote code execution possible. This was partially patched in 9.9, and sufficiently patched in 10.0. CVE-2024-37231 appears to be a duplicate of this issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Salon Booking System 9.8 premières → 9.8 Pas de correctif indiqué
Salon Booking System – Free Version 9.9 premières → 9.9 Pas de correctif indiqué
Les 5 CVE de Salon Booking System →
Suivre cette CVE