7.4
Élevée
CVE-2024-35220 @fastify/session is a session plugin for fastify
Description
@fastify/session is a session plugin for fastify. Requires the @fastify/cookie plugin. When restoring the cookie from the session store, the `expires` field is overriden if the `maxAge` field was set. This means a cookie is never correctly detected as expired and thus expired sessions are not destroyed. This vulnerability has been patched 10.8.0.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| session 10.9 | premières → < 10.9.0 | 10.9.0 |