Aller au contenu
7.5 Élevée

CVE-2024-27919 Envoy is a cloud-native, open-source edge and service proxy

Description

Envoy is a cloud-native, open-source edge and service proxy. In versions 1.29.0 and 1.29.1, theEnvoy HTTP/2 protocol stack is vulnerable to the flood of CONTINUATION frames. Envoy's HTTP/2 codec does not reset a request when header map limits have been exceeded. This allows an attacker to send an sequence of CONTINUATION frames without the END_HEADERS bit set causing unlimited memory consumption. This can lead to denial of service through memory exhaustion. Users should upgrade to versions 1.29.2 to mitigate the effects of the CONTINUATION flood. Note that this vulnerability is a regression in Envoy version 1.29.0 and 1.29.1 only. As a workaround, downgrade to version 1.28.1 or earlier or disable HTTP/2 protocol for downstream connections.

Produits et versions touchés

Produit Versions touchées Corrigé en
envoy 1.29 1.29.0 → < 1.29.2 1.29.2

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 98 CVE de envoy →
Suivre cette CVE