Aller au contenu
4.3 Moyenne

CVE-2024-24772 A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak…

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Superset 3.1 3.1.0 → < 3.1.1 3.1.1
Apache Superset 3.0 premières → < 3.0.4 3.0.4

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 65 CVE de Apache Superset →
Suivre cette CVE