Non notée
CVE-2024-22369 Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0…
Description
Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Camel 4.1 | 4.1.0 → < 4.4.0 | 4.4.0 |
| Apache Camel 4.0 | 4.0.0 → < 4.0.4 | 4.0.4 |
| Apache Camel 3.22 | 3.22.0 → < 3.22.1 | 3.22.1 |
| Apache Camel 3.0 | 3.0.0 → < 3.21.4 | 3.21.4 |
| camel 4.1 | 4.1.0 → < 4.4.0 | 4.4.0 |
| camel 4.0 | 4.0.0 → < 4.0.4 | 4.0.4 |
| camel 3.22 | 3.22.0 → < 3.22.1 | 3.22.1 |
| camel 3.0 | 3.0.0 → < 3.21.4 | 3.21.4 |
Références
- lists.apache.org lists.apache.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Apache Camel
Les 97 CVE de Apache Camel →
CVE-2026-71569
Server-Side Request Forgery (SSRF) vulnerability in Apache Camel A2A component
4.8
Moyenne
CVE-2026-90885
Improper Restriction of XML External Entity Reference vulnerability in Apache Camel Saxon component
7.5
Élevée
CVE-2026-94386
Use of Cache Containing Sensitive Information vulnerability in Apache Camel Oauth component
4.8
Moyenne
CVE-2026-95628
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Apache Camel Docling…
5.4
Moyenne