5.3
Moyenne
CVE-2024-14043 A vulnerability was determined in Open5GS up to 2.7.1
Description
A vulnerability was determined in Open5GS up to 2.7.1. This vulnerability affects the function mme_s6a_subscription_data_from_avp of the file src/mme/mme-fd-path.c of the component Diameter S6a Interface. Executing a manipulation of the argument msisdn_len can lead to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been publicly disclosed and may be utilized. Upgrading to version 2.7.2 is able to resolve this issue. This patch is called 7ea82cb87bb65c3694d8d7c7a5efed1c4d3c9304. Upgrading the affected component is recommended.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Open5GS 2.7 | 2.7.0 → 2.7.1 | 2.7.2 |
Références
- VDB-387281 | Open5GS Diameter S6a mme-fd-path.c mme_s6a_subscription_data_from_avp heap-based overflow vuldb.com
- VDB-387281 | CTI Indicators (IOB, IOC, IOA) vuldb.com
- CVE-2024-14043 | CVE Analysis and Report vuldb.com
- Submit #867106 | Open5GS V2.7.2 Memory Corruption vuldb.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Chronologie
- Publiée
- Dernière modification
Autres CVE de Open5GS
Les 125 CVE de Open5GS →
CVE-2026-107166
A weakness has been identified in Open5GS up to 2.7.7
6.9
Moyenne
CVE-2026-92417
A vulnerability was found in Open5GS up to 2.8.0
7.1
Élevée
CVE-2026-92416
A vulnerability has been found in Open5GS up to 2.8.0
5.3
Moyenne
CVE-2026-91855
A security flaw has been discovered in Open5GS up to 2.7.7
6.9
Moyenne