Aller au contenu
8.1 Élevée

CVE-2024-11917 The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and…

Description

The JobSearch WP Job Board plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 2.9.2. This is due to improper configurations in the 'jobsearch_xing_response_data_callback', 'set_access_tokes', and 'google_callback' functions. This makes it possible for unauthenticated attackers to log in as the first connected Xing user, or any connected Xing user if the Xing id is known. It is also possible for unauthenticated attackers to log in as the first connected Google user if the user has logged in, without subsequently logging out, in thirty days. The vulnerability was partially patched in version 2.8.4.

Produits et versions touchés

Produit Versions touchées Corrigé en
JobSearch WP Job Board 2.9 premières → 2.9.2 Pas de correctif indiqué
Les 7 CVE de JobSearch WP Job Board →
Suivre cette CVE