Aller au contenu
7.4 Élevée

CVE-2023-51437 Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge…

Description

Observable timing discrepancy vulnerability in Apache Pulsar SASL Authentication Provider can allow an attacker to forge a SASL Role Token that will pass signature verification. Users are recommended to upgrade to version 2.11.3, 3.0.2, or 3.1.1 which fixes the issue. Users should also consider updating the configured secret in the `saslJaasServerRoleTokenSignerSecretPath` file. Any component matching an above version running the SASL Authentication Provider is affected. That includes the Pulsar Broker, Proxy, Websocket Proxy, or Function Worker. 2.11 Pulsar users should upgrade to at least 2.11.3. 3.0 Pulsar users should upgrade to at least 3.0.2. 3.1 Pulsar users should upgrade to at least 3.1.1. Any users running Pulsar 2.8, 2.9, 2.10, and earlier should upgrade to one of the above patched versions. For additional details on this attack vector, please refer to https://codahale.com/a-lesson-in-timing-attacks/ .

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Pulsar 3.1.0 Pas de correctif indiqué
Apache Pulsar 3.0 3.0.0 → 3.0.1 Pas de correctif indiqué
Apache Pulsar 2.11 2.11.0 → 2.11.2 Pas de correctif indiqué
Apache Pulsar 2.10 premières → 2.10.5 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 30 CVE de Apache Pulsar →
Suivre cette CVE