Non notée
CVE-2023-46215 Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow
Description
Insertion of Sensitive Information into Log File vulnerability in Apache Airflow Celery provider, Apache Airflow. Sensitive information logged as clear text when rediss, amqp, rpc protocols are used as Celery result backend Note: the vulnerability is about the information exposed in the logs not about accessing the logs. This issue affects Apache Airflow Celery provider: from 3.3.0 through 3.4.0; Apache Airflow: from 1.10.0 through 2.6.3. Users are recommended to upgrade Airflow Celery provider to version 3.4.1 and Apache Airlfow to version 2.7.0 which fixes the issue.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Apache Airflow Celery provider 3.3 | 3.3.0 → 3.4.0 | Pas de correctif indiqué |
| Apache Airflow 1.10 | 1.10.0 → < 2.7.0 | 2.7.0 |
Références
- github.com github.com
- lists.apache.org lists.apache.org
- www.openwall.com www.openwall.com
Chronologie
- Publiée
- Dernière modification