Aller au contenu
Non notée

CVE-2023-45648 Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1…

Description

Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Tomcat 11.0 11.0.0-M1 → 11.0.0-M11 Pas de correctif indiqué
Apache Tomcat 10.1 10.1.0-M1 → 10.1.13 Pas de correctif indiqué
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 Pas de correctif indiqué
Apache Tomcat 9.0 9.0.0-M1 → 9.0.81 Pas de correctif indiqué
Apache Tomcat 8.5 8.5.0 → 8.5.93 Pas de correctif indiqué
Apache Tomcat 3 3 → < 8.5.0 8.5.0
Tomcat 11.0 11.0.0-m1 → 11.0.0-m11 Pas de correctif indiqué
Tomcat 10.1 10.1.0-m1 → 10.1.13 Pas de correctif indiqué
Tomcat 9.0 9.0.0-m1 → 9.0.81 Pas de correctif indiqué
Afficher l’autre branche
Produit Versions touchées Corrigé en
Tomcat 8.5 8.5.0 → 8.5.93 Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 141 CVE de Apache Tomcat →
Suivre cette CVE