7.5
Élevée
CVE-2023-39417 IN THE EXTENSION SCRIPT, a SQL Injection vulnerability was found in PostgreSQL if it uses @extowner@, @extschema@, or…
Description
IN THE EXTENSION SCRIPT, a SQL Injection vulnerability was found in PostgreSQL if it uses @extowner@, @extschema@, or @extschema:...@ inside a quoting construct (dollar quoting, '', or ""). If an administrator has installed files of a vulnerable, trusted, non-bundled extension, an attacker with database-level CREATE privilege can execute arbitrary code as the bootstrap superuser.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Red Hat Advanced Cluster Security 4.2 4.2 | premières → < 4.2.4-7 | 4.2.4-7 |
| Red Hat Enterprise Linux 8 | Versions non publiées | |
| Red Hat Enterprise Linux 8.2 Advanced Update Support 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Telecommunications Update Service 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.2 Update Services for SAP Solutions 8020020231128165246.4 | premières → < 8020020231128165246.4cda2c84 | 8020020231128165246.4cda2c84 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Telecommunications Update Service 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Update Services for SAP Solutions 8040020231127154806.522 | premières → < 8040020231127154806.522a0ee4 | 8040020231127154806.522a0ee4 |
| Red Hat Enterprise Linux 8.6 Extended Update Support 8060020231128165328 | premières → < 8060020231128165328.ad008a3a | 8060020231128165328.ad008a3a |
Afficher les 10 autres branches Masquer les 10 autres branches
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| Red Hat Enterprise Linux 8.8 Extended Update Support 8080020231113134015.63 | premières → < 8080020231113134015.63b34585 | 8080020231113134015.63b34585 |
| Red Hat Enterprise Linux 9 9030020231120082734 | premières → < 9030020231120082734.rhel9 | 9030020231120082734.rhel9 |
| Red Hat Enterprise Linux 9.0 Extended Update Support | Versions non publiées | |
| Red Hat Enterprise Linux 9.2 Extended Update Support 9020020231115020618 | premières → < 9020020231115020618.rhel9 | 9020020231115020618.rhel9 |
| Red Hat Software Collections for Red Hat Enterprise Linux 7 | Versions non publiées | |
| RHACS-3.74-RHEL-8 3.74 | premières → < 3.74.8-9 | 3.74.8-9 |
| RHACS-4.1-RHEL-8 4.1 | premières → < 4.1.6-6 | 4.1.6-6 |
| Red Hat Enterprise Linux 6 | Versions non publiées | |
| Red Hat Enterprise Linux 7 | Versions non publiées | |
| Red Hat Software Collections | Versions non publiées |
Références
- RHSA-2023:7545 access.redhat.com
- RHSA-2023:7579 access.redhat.com
- RHSA-2023:7580 access.redhat.com
- RHSA-2023:7581 access.redhat.com
- RHSA-2023:7616 access.redhat.com
- RHSA-2023:7656 access.redhat.com
- RHSA-2023:7666 access.redhat.com
- RHSA-2023:7667 access.redhat.com
- RHSA-2023:7694 access.redhat.com
- RHSA-2023:7695 access.redhat.com
- RHSA-2023:7714 access.redhat.com
- RHSA-2023:7770 access.redhat.com
- RHSA-2023:7772 access.redhat.com
- RHSA-2023:7784 access.redhat.com
- RHSA-2023:7785 access.redhat.com
- RHSA-2023:7883 access.redhat.com
- RHSA-2023:7884 access.redhat.com
- RHSA-2023:7885 access.redhat.com
- RHSA-2024:0304 access.redhat.com
- RHSA-2024:0332 access.redhat.com
- RHSA-2024:0337 access.redhat.com
- access.redhat.com access.redhat.com
- RHBZ#2228111 bugzilla.redhat.com
- www.postgresql.org www.postgresql.org
Chronologie
- Publiée
- Dernière modification
Autres CVE de Red Hat Advanced Cluster Security 4.2
Les 5 CVE de Red Hat Advanced Cluster Security 4.2 →
CVE-2023-4958
In Red Hat Advanced Cluster Security (RHACS), it was found that some security related HTTP headers were missing,…
6.1
Moyenne
CVE-2023-5870
A flaw was found in PostgreSQL involving the pg_cancel_backend role that signals background workers, including the…
2.2
Faible
CVE-2023-5869
Postgresql: buffer overrun from integer overflow in array modification
8.8
Élevée
CVE-2023-5868
Postgresql: memory disclosure in aggregate function calls
4.3
Moyenne