Aller au contenu
7.5 Élevée

CVE-2023-37544 Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong…

Description

Improper Authentication vulnerability in Apache Pulsar WebSocket Proxy allows an attacker to connect to the /pingpong endpoint without authentication. This issue affects Apache Pulsar WebSocket Proxy: from 2.8.0 through 2.8.*, from 2.9.0 through 2.9.*, from 2.10.0 through 2.10.4, from 2.11.0 through 2.11.1, 3.0.0. The known risks include a denial of service due to the WebSocket Proxy accepting any connections, and excessive data transfer due to misuse of the WebSocket ping/pong feature. 2.10 Pulsar WebSocket Proxy users should upgrade to at least 2.10.5. 2.11 Pulsar WebSocket Proxy users should upgrade to at least 2.11.2. 3.0 Pulsar WebSocket Proxy users should upgrade to at least 3.0.1. 3.1 Pulsar WebSocket Proxy users are unaffected. Any users running the Pulsar WebSocket Proxy for 2.8, 2.9, and earlier should upgrade to one of the above patched versions.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Pulsar WebSocket Proxy 3.0.0 Pas de correctif indiqué
Apache Pulsar WebSocket Proxy 2.11 2.11.0 → 2.11.1 Pas de correctif indiqué
Apache Pulsar WebSocket Proxy 2.10 2.10.0 → 2.10.4 Pas de correctif indiqué
Apache Pulsar WebSocket Proxy 2.9 2.9.0 → dernières Pas de correctif indiqué
Apache Pulsar WebSocket Proxy 2.8 2.8.0 → dernières Pas de correctif indiqué

Références

Chronologie

  1. Publiée
  2. Dernière modification
Suivre cette CVE