Aller au contenu
Non notée

CVE-2023-31039 Security vulnerability in Apache…

Description

Security vulnerability in Apache bRPC <1.5.0 on all platforms allows attackers to execute arbitrary code via ServerOptions::pid_file. An attacker that can influence the ServerOptions pid_file parameter with which the bRPC server is started can execute arbitrary code with the permissions of the bRPC process. Solution: 1. upgrade to bRPC >= 1.5.0, download link:  https://dist.apache.org/repos/dist/release/brpc/1.5.0/ https://dist.apache.org/repos/dist/release/brpc/1.5.0/ 2. If you are using an old version of bRPC and hard to upgrade, you can apply this patch:  https://github.com/apache/brpc/pull/2218 https://github.com/apache/brpc/pull/2218

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache bRPC 0.9 0.9.0 → < 1.5.0 1.5.0
brpc 0.9 0.9.0 → < 1.5.0 1.5.0

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 41 CVE de Apache bRPC →
Suivre cette CVE