Aller au contenu
8.0 Élevée

CVE-2022-45064 The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of…

Description

The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.

Produits et versions touchés

Produit Versions touchées Corrigé en
Apache Sling Engine 2.14 premières → < 2.14.0 2.14.0
sling 2.14 premières → < 2.14.0 2.14.0

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 4 CVE de Apache Sling Engine →
Suivre cette CVE