4.0
Moyenne
CVE-2022-0317 An improper input validation vulnerability in go-attestation before 0.3.3 allows local users to provide a…
Description
An improper input validation vulnerability in go-attestation before 0.3.3 allows local users to provide a maliciously-formed Quote over no/some PCRs, causing AKPublic.Verify to succeed despite the inconsistency. Subsequent use of the same set of PCR values in Eventlog.Verify lacks the authentication performed by quote verification, meaning a local attacker could couple this vulnerability with a maliciously-crafted TCG log in Eventlog.Verify to spoof events in the TCG log, hence defeating remotely-attested measured-boot. We recommend upgrading to Version 0.4.0 or above.
Produits et versions touchés
| Produit | Versions touchées | Corrigé en |
|---|---|---|
| go-attestation 0.4 | premières → < 0.4.0 | 0.4.0 |