Aller au contenu
7.5 Élevée

CVE-2021-39178 Next.js is a React framework

Description

Next.js is a React framework. Versions of Next.js between 10.0.0 and 11.0.0 contain a cross-site scripting vulnerability. In order for an instance to be affected by the vulnerability, the `next.config.js` file must have `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default or the instance is deployed on Vercel, the instance is not affected by the vulnerability. The vulnerability is patched in Next.js version 11.1.1.

Produits et versions touchés

Produit Versions touchées Corrigé en
next.js 10.0 10.0.0 → < 11.1.1 11.1.1

Références

Chronologie

  1. Publiée
  2. Dernière modification
Les 57 CVE de next.js →
Suivre cette CVE