Aller au contenu
6.4 Moyenne

CVE-2020-8904 An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0

Description

An arbitrary memory overwrite vulnerability in the trusted memory of Asylo exists in versions prior to 0.6.0. As the ecall_restore function fails to validate the range of the output_len pointer, an attacker can manipulate the tmp_output_len value and write to an arbitrary location in the trusted (enclave) memory. We recommend updating Asylo to version 0.6.0 or later.

Produits et versions touchés

Produit Versions touchées Corrigé en
Asylo 0.6 premières → < 0.6.0 0.6.0
Les 16 CVE de Asylo →
Suivre cette CVE