| CVE-2026-40466 |
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ…
|
Not rated
|
Apr 24, 2026 |
| CVE-2026-39304 |
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ
|
Not rated
|
Apr 10, 2026 |
| CVE-2026-40046 |
Integer Overflow or Wraparound vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ MQTT
|
Not rated
|
Apr 9, 2026 |
| CVE-2026-33227 |
Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache…
|
Not rated
|
Apr 7, 2026 |
| CVE-2026-34197 |
Exploited
Apache ActiveMQ Improper Input Validation Vulnerability
|
Not rated
|
Apr 7, 2026 |
| CVE-2025-66168 |
WARNING:
Users of 6.x should upgrade to 6.2.4 or later as the fix was missed in previous 6.x releases
|
5.4
Medium
|
Mar 4, 2026 |
| CVE-2025-27533 |
Memory Allocation with Excessive Size Value vulnerability in Apache ActiveMQ
|
6.9
Medium
|
May 7, 2025 |
| CVE-2024-32114 |
In Apache ActiveMQ 6.x, the default configuration doesn't secure the API web context (where the Jolokia JMX REST API and…
|
8.5
High
|
May 2, 2024 |
| CVE-2022-41678 |
Once an user is authenticated on Jolokia, he can potentially trigger arbitrary code execution. In details, in…
|
Not rated
|
Nov 28, 2023 |
| CVE-2023-46604 |
Exploited
Apache ActiveMQ Deserialization of Untrusted Data Vulnerability
|
10.0
Critical
|
Oct 27, 2023 |
| CVE-2021-26117 |
The optional ActiveMQ LDAP login module can be configured to use anonymous access to the LDAP server
|
Not rated
|
Jan 27, 2021 |
| CVE-2018-8006 |
An instance of a cross-site scripting vulnerability was identified to be present in the web based administration console…
|
Not rated
|
Oct 10, 2018 |
| CVE-2018-11775 |
TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client…
|
Not rated
|
Sep 10, 2018 |
| CVE-2017-15709 |
When using the OpenWire protocol in ActiveMQ versions 5.14.0 to 5.15.2 it was found that certain system details (such as…
|
Not rated
|
Feb 13, 2018 |
| CVE-2016-6810 |
In Apache ActiveMQ 5.x before 5.14.2, an instance of a cross-site scripting vulnerability was identified to be present…
|
Not rated
|
Jan 10, 2018 |