Skip to content
Not rated

CVE-2026-77147 Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope

Description

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy Command class containing untrusted code in their CommandArgs static implementation, bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fix this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Syncope 4.1 4.1.0-M0 → 4.1.2 No fix stated
Apache Syncope 4.0 4.0.0-M0 → 4.0.7 No fix stated
Apache Syncope 3.0 3.0.0-M0 → 3.0.16 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 45 CVEs of Apache Syncope →
Track this CVE