Skip to content
Not rated

CVE-2026-62183 Improper Privilege Management vulnerability in Apache Syncope

Description

Improper Privilege Management vulnerability in Apache Syncope. When: * the all-Java user workflow adapter is configured, or * the Flowable user workflow adapter is configured, bearing a BPMN definition not requiring admin approval for user self registration of self update requests the following scenario could happen. A REST API call can allow the user to grant themselves one or more of defined Roles, thus gaining their Entitlements and becoming in fact an administrator; the actual Entitlements gained depend on the Roles that are effectively defined on the specific Syncope deployment. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 Through 4.0.6, from 4.1.0-M0 through 4.1.1. Users are recommended to upgrade to version 4.0.7 / 4.1.2, which fix this issue.

Affected products and versions

Product Affected versions Fixed in
Apache Syncope 4.1 4.1.0-M0 → 4.1.1 No fix stated
Apache Syncope 4.0 4.0.0-M0 → 4.0.6 No fix stated
Apache Syncope 3.0 3.0.0-M0 → 3.0.16 No fix stated
The 45 CVEs of Apache Syncope →
Track this CVE