Skip to content
4.7 Medium

CVE-2026-44581 Next.js is a React framework for building full-stack web applications

Description

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected products and versions

Product Affected versions Fixed in
next.js 16.0 16.0.0 → < 16.2.5 16.2.5
next.js 13.4 13.4.0 → < 15.5.16 15.5.16

References

Timeline

  1. Published
  2. Last modified
The 57 CVEs of next.js →
Track this CVE