Skip to content
6.1 Medium

CVE-2026-44580 Next.js is a React framework for building full-stack web applications

Description

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Affected products and versions

Product Affected versions Fixed in
next.js 16.0 16.0.0 → < 16.2.5 16.2.5
next.js 13.0 13.0.0 → < 15.5.16 15.5.16

References

Timeline

  1. Published
  2. Last modified
The 57 CVEs of next.js →
Track this CVE