Skip to content
7.8 High

CVE-2026-4295 Improper trust boundary enforcement in Kiro IDE before version 0.8.0 on all supported platforms might allow a remote…

Description

Improper trust boundary enforcement in Kiro IDE before version 0.8.0 on all supported platforms might allow a remote unauthenticated threat actor to execute arbitrary code via maliciously crafted project directory files that bypass workspace trust protections when a local user opens the directory. To remediate this issue, users should upgrade to version 0.8.0 or higher.

Affected products and versions

Product Affected versions Fixed in
Kiro IDE 0.1 0.1.0 → < 0.8.0 0.8.0
The 6 CVEs of Kiro IDE →
Track this CVE