Skip to content
Not rated

CVE-2026-42797 Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope

Description

Exposure of Sensitive Information Through Data Queries vulnerability in Apache Syncope. An administrator with adequate entitlements for Derived Schemas can create a malicious JEXL expression which allows any administrator with sufficient entitlements for User read to access User-related security-sensitive information. This issue affects Apache Syncope: 3.0 through 3.0.16, 4.0 through 4.0.5, 4.1.0. Users are recommended to upgrade to version 4.0.6 / 4.1.1, which fix this issue by further restricting the JEXL expression definition.

Affected products and versions

Product Affected versions Fixed in
Apache Syncope 4.1 4.1 → 4.1.0 No fix stated
Apache Syncope 4.0 4.0 → 4.0.5 No fix stated
Apache Syncope 3.0 3.0 → 3.0.16 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 45 CVEs of Apache Syncope →
Track this CVE