Not rated
CVE-2026-42509 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket. This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0. Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Wicket 10.0 | 10.0.0 → 10.8.0 | No fix stated |
| Apache Wicket 9.0 | 9.0.0 → 9.22.0 | No fix stated |
| Apache Wicket 8.0 | 8.0.0 → 8.17.0 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified
Other CVEs of Apache Wicket
The 40 CVEs of Apache Wicket →
CVE-2026-111089
Apache Wicket reads texts from the application's resource bundles — a localized label, a css class name — and writes…
7.6
High
CVE-2026-95863
Improper neutralization of input during web page generation in Apache Wicket
7.6
High
CVE-2026-87718
Apache Wicket 10.10.0, 10.11.0 and 9.24.0 do not set the Content-Security-Policy headers on a page whose render…
2.3
Low
CVE-2026-84231
Improper neutralization of input during web page generation in Apache Wicket
7.4
High