Skip to content
7.4 High

CVE-2026-35560 Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before…

Description

Improper certificate validation in the identity provider connection components in Amazon Athena ODBC driver before 2.1.0.0 might allow a man-in-the-middle threat actor to intercept authentication credentials due to insufficient default transport security when connecting to identity providers. This only applies to connections with external identity providers and does not apply to connections with Athena. To remediate this issue, users should upgrade to version 2.1.0.0.

Affected products and versions

Product Affected versions Fixed in
Amazon Athena ODBC driver 2.1 earliest → < 2.1.0.0 2.1.0.0
The 6 CVEs of Amazon Athena ODBC driver →
Track this CVE