Skip to content
6.5 Medium

CVE-2026-34756 vLLM is an inference and serving engine for large language models (LLMs)

Description

vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.19.0, a Denial of Service vulnerability exists in the vLLM OpenAI-compatible API server. Due to the lack of an upper bound validation on the n parameter in the ChatCompletionRequest and CompletionRequest Pydantic models, an unauthenticated attacker can send a single HTTP request with an astronomically large n value. This completely blocks the Python asyncio event loop and causes immediate Out-Of-Memory crashes by allocating millions of request object copies in the heap before the request even reaches the scheduling queue. This vulnerability is fixed in 0.19.0.

Affected products and versions

Product Affected versions Fixed in
vllm 0.1 0.1.0 → < 0.19.0 0.19.0
Red Hat AI Inference Server Versions not published
Red Hat Enterprise Linux AI (RHEL AI) 3 Versions not published
Red Hat OpenShift AI (RHOAI) Versions not published
Red Hat AI Inference Server 3.2 1782951244 earliest → < 1782951244 1782951244
Red Hat AI Inference Server 3.4 1787151774 earliest → < 1787151774 1787151774
Red Hat Enterprise Linux AI 3.4 1787244006 earliest → < 1787244006 1787244006

References

Timeline

  1. Published
  2. Last modified
The 121 CVEs of vllm →
Track this CVE