Skip to content
5.3 Medium

CVE-2026-2704 A security vulnerability has been detected in Open Babel up to 3.1.1

Description

A security vulnerability has been detected in Open Babel up to 3.1.1. The affected element is the function OpenBabel::transform3d::DescribeAsString of the file src/math/transform3d.cpp of the component CIF File Handler. The manipulation leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 3.2.0 is sufficient to fix this issue. The identifier of the patch is e23a224b8fd9d7c2a7cde9ef4ec6afb4c05aa08a. It is suggested to install a patch to address this issue.

Affected products and versions

Product Affected versions Fixed in
Open Babel 3.2 earliest → < 3.2.0 3.2.0
Open Babel 3.1 3.1.0 → 3.1.1 No fix stated
The 10 CVEs of Open Babel →
Track this CVE