Skip to content
Not rated

CVE-2026-25917 Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing…

Description

Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low. Users are recommended to upgrade to Apache Airflow 3.2.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Airflow 3.0 3.0.0 → < 3.2.0 3.2.0

References

Timeline

  1. Published
  2. Last modified
The 153 CVEs of Apache Airflow →
Track this CVE