10.0
Critical
CVE-2026-112816 Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15,…
Description
Improper certificate validation in the HTTPS listener in Canonical LXD 4.0.14, 5.0.10, 5.21.8, 6.9 before 4.0.15, 5.0.11, 5.21.9, 6.10.1 allows an unauthenticated attacker to authenticate as any trusted client and gain full access to the cluster and managed virtual machines via a crafted certificate chain.
Affected products and versions
References
- github.com github.com
- discourse.ubuntu.com discourse.ubuntu.com
- discourse.ubuntu.com discourse.ubuntu.com
- discourse.ubuntu.com discourse.ubuntu.com
- discourse.ubuntu.com discourse.ubuntu.com
- discourse.ubuntu.com discourse.ubuntu.com
Timeline
- Published
- Last modified
Other CVEs of LXD
The 47 CVEs of LXD →
CVE-2026-87798
Improper link resolution in the recursive file pull feature of the LXD CLI client in Canonical LXD versions 4.0.2 up…
5.8
Medium
CVE-2026-87799
Improper link resolution in the migration receive path in Canonical LXD versions 4.0 and later (fixed in 4.0.14, 5.0.10,…
9.9
Critical
CVE-2026-97335
Incorrect authorization in the custom storage volume creation endpoint in Canonical LXD versions 5.0.0 and later…
7.7
High
CVE-2026-85185
Path traversal in the btrfs storage driver in Canonical LXD versions 4.0.2 and later (fixed in 4.0.14, 5.0.10, 5.21.8…
9.6
Critical