Skip to content
5.3 Medium

CVE-2026-110310 A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding…

Description

A remote user who can read encrypted objects in the S3 bucket can force a padding downgrade by altering the padding scheme recorded in an object's metadata to legacy PKCS#1 v1.5. Since this padding scheme is susceptible to the well-known Bleichenbacher attack, the user can use a PKCS#1 v1.5 padding oracle to recover the RSA-wrapped envelope key and decrypt the object. To remediate this issue, we recommend that users upgrade to version 3.2.2 or 4.0.3. The 1.x and 2.x lines will not be patched, users of those lines need to migrate to 3.2.2 or 4.0.3.

Affected products and versions

Product Affected versions Fixed in
Amazon.Extensions.S3.Encryption 4.0 4.0.0 → 4.0.2 No fix stated
Amazon.Extensions.S3.Encryption 3.0 3.0.0 → 3.2.1 No fix stated
Amazon.Extensions.S3.Encryption 2.1 2.1.0 → latest No fix stated
Track this CVE