6.9
Medium
CVE-2026-103663 Ollama is vulnerable to path traversal in the `/api/pull` endpoint due to insufficient validation of layer digests by…
Description
Ollama is vulnerable to path traversal in the `/api/pull` endpoint due to insufficient validation of layer digests by the `digestToPath` function. An unauthenticated remote attacker can specify a path traversal sequence as a layer digest, causing a malicious binary to be written outside the model store. Critically if the server process has write access to `/usr/lib/ollama` (the default in most Ollama Docker images), an attacker can write the malicious file to that directory. On the next server restart, the file is loaded and executed, resulting in remote code execution as root. This issue was fixed in version 0.35.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Ollama 0.34 | 0.34.2 → < 0.35.0 | 0.35.0 |
References
- cert.pl cert.pl
- ollama.com ollama.com
Timeline
- Published
- Last modified
Other CVEs of Ollama
The 14 CVEs of Ollama →
CVE-2026-102697
Ollama versions 0.14.0 before 0.31.2 contain an incorrect authorization vulnerability in the experimental agent mode…
8.5
High
CVE-2026-85180
Ollama fails to validate redirect destinations when pulling tensor-layer models, allowing unauthenticated attackers to…
8.7
High
CVE-2026-65315
Ollama (HEAD f0078ae) contains an uncontrolled memory allocation vulnerability in the GGUF metadata parser that allows…
8.7
High
CVE-2026-15685
Ollama downloadBlob Improper Validation of Array Index Denial-of-Service Vulnerability
7.5
High