Skip to content
Not rated

CVE-2026-103552 Stack Overflow vulnerability in Apache Directory LDAP API

Description

Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects Apache Directory LDAP API: from 1.2.0 before 1.2.9. Users are recommended to upgrade to version 1.2.9, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Directory LDAP API 1.2 1.2.0 → < 1.2.9 1.2.9

References

Timeline

  1. Published
  2. Last modified
The 7 CVEs of Apache Directory LDAP API →
Track this CVE