Skip to content
8.1 High

CVE-2026-102827 simple-git, an interface for running git commands in any node.js application, enables applications to execute Git…

Description

simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. Prior to 4.0.0, the default blockUnsafeOperationsPlugin compares parsed option names with literal dangerous option spellings while Git accepts unambiguous long-option abbreviations. Attacker-influenced push arguments such as abbreviated --receive-pack or --exec forms can therefore bypass detectVulnerableFlags, reach git push against a local or file remote or an attacker-influenced receive-pack target, and cause Git to invoke an attacker-selected command in consumers that expose those arguments. The clone-side abbreviation handling does not protect the push path. This issue is fixed in 4.0.0.

Affected products and versions

Product Affected versions Fixed in
git-js 4.0 earliest → < 4.0.0 4.0.0

References

Timeline

  1. Published
  2. Last modified
The 5 CVEs of git-js →
Track this CVE