3.8
Low
CVE-2025-66215 OpenSC is an open source smart card tools and middleware
Description
OpenSC is an open source smart card tools and middleware. Prior to version 0.27.0, an attacker with physical access to the computer at the time user or administrator uses a token can cause a stack-buffer-overflow WRITE in card-oberthur. The attack requires crafted USB device or smart card that would present the system with specially crafted responses to the APDUs. This issue has been patched in version 0.27.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| OpenSC 0.27 | earliest → < 0.27.0 | 0.27.0 |
References
- github.com github.com
- github.com github.com
- github.com github.com
- github.com github.com
Timeline
- Published
- Last modified
Other CVEs of OpenSC
The 7 CVEs of OpenSC →
CVE-2026-40528
OpenSC before 0.27.0, fixed in commit 0358817, contains a stack and heap buffer overrun vulnerability in the…
1.0
Low
CVE-2026-40510
OpenSC before 0.27.0-rc1, fixed in commit 3f24f0b, contains a stack buffer overflow vulnerability in…
1.0
Low
CVE-2025-13763
Multiple uses of uninitialized variables were found in libopensc that may lead to information disclosure or…
5.7
Medium
CVE-2025-66038
OpenSC is an open source smart card tools and middleware
3.9
Low