Skip to content
Not rated

CVE-2025-66170 The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0

Description

The CloudStack Backup plugin has an improper authorization logic in versions 4.21.0.0 and 4.22.0.0. Anyone with authenticated user-account access in CloudStack 4.21.0.0+ environments, where this plugin is enabled and has access to specific APIs can list backups from any account in the environment. This vulnerability does not allow them to see the contents of the backup. Users are recommended to upgrade to version 4.22.0.1, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.21 4.21.0.0 → 4.22.0.0 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 51 CVEs of Apache CloudStack →
Track this CVE