Not rated
CVE-2025-66169 Cypher Injection vulnerability in Apache Camel camel-neo4j component
Description
Cypher Injection vulnerability in Apache Camel camel-neo4j component. This issue affects Apache Camel: from 4.10.0 before 4.10.8, from 4.14.0 before 4.14.3, from 4.15.0 before 4.17.0 Users are recommended to upgrade to version 4.10.8 for 4.10.x LTS and 4.14.3 for 4.14.x LTS and 4.17.0.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Camel Neo4j 4.15 | 4.15.0 → < 4.17.0 | 4.17.0 |
| Apache Camel Neo4j 4.14 | 4.14.0 → < 4.14.3 | 4.14.3 |
| Apache Camel Neo4j 4.10 | 4.10.0 → < 4.10.8 | 4.10.8 |
References
- camel.apache.org camel.apache.org
Timeline
- Published
- Last modified