Skip to content
Not rated

CVE-2025-59302 Apache CloudStack: Potential remote code execution on Javascript engine defined rules

Description

In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.

Affected products and versions

Product Affected versions Fixed in
Apache CloudStack 4.21 4.21.0 → < 4.22.0 4.22.0
Apache CloudStack 4.18 4.18.0 → < 4.20.2 4.20.2

References

Timeline

  1. Published
  2. Last modified
The 51 CVEs of Apache CloudStack →
Track this CVE