Not rated
CVE-2025-58782 Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons
Description
Deserialization of Untrusted Data vulnerability in Apache Jackrabbit Core and Apache Jackrabbit JCR Commons. This issue affects Apache Jackrabbit Core: from 1.0.0 through 2.22.1; Apache Jackrabbit JCR Commons: from 1.0.0 through 2.22.1. Deployments that accept JNDI URIs for JCR lookup from untrusted users allows them to inject malicious JNDI references, potentially leading to arbitrary code execution through deserialization of untrusted data. Users are recommended to upgrade to version 2.22.2. JCR lookup through JNDI has been disabled by default in 2.22.2. Users of this feature need to enable it explicitly and are adviced to review their use of JNDI URI for JCR lookup.
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Apache Jackrabbit Core 1.0 | 1.0.0 → 2.22.1 | No fix stated |
| Apache Jackrabbit JCR Commons 1.0 | 1.0.0 → 2.22.1 | No fix stated |
References
- lists.apache.org lists.apache.org
Timeline
- Published
- Last modified