Skip to content
5.3 Medium

CVE-2025-55675 Apache Superset contains an improper access control vulnerability in its /explore endpoint

Description

Apache Superset contains an improper access control vulnerability in its /explore endpoint. A missing authorization check allows an authenticated user to discover metadata about datasources they do not have permission to access. By iterating through the datasource_id in the URL, an attacker can enumerate and confirm the existence and names of protected datasources, leading to sensitive information disclosure. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Superset 5.0 earliest → < 5.0.0 5.0.0

References

Timeline

  1. Published
  2. Last modified
The 65 CVEs of Apache Superset →
Track this CVE