Skip to content
Not rated

CVE-2025-55668 Session Fixation vulnerability in Apache Tomcat via rewrite valve

Description

Session Fixation vulnerability in Apache Tomcat via rewrite valve. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.7 No fix stated
Apache Tomcat 10.1 10.1.0-M1 → 10.1.41 No fix stated
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 No fix stated
Apache Tomcat 9.0 9.0.0.M1 → 9.0.105 No fix stated
Apache Tomcat 8 8 → < 9.0.0.M1 9.0.0.M1

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE