Skip to content
Not rated

CVE-2025-49124 Untrusted Search Path vulnerability in Apache Tomcat installer for Windows

Description

Untrusted Search Path vulnerability in Apache Tomcat installer for Windows. During installation, the Tomcat installer for Windows used icacls.exe without specifying a full path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0 through 10.1.41, from 9.0.23 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100 and 7.0.95 through 7.0.109. Other EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat 11.0 11.0.0-M1 → 11.0.7 No fix stated
Apache Tomcat 10.1 10.1.0 → 10.1.41 No fix stated
Apache Tomcat 10.0 10.0.0-M1 → 10.0.27 No fix stated
Apache Tomcat 9.0 9.0.23 → 9.0.105 No fix stated
Apache Tomcat 8.5 8.5.44 → 8.5.100 No fix stated
Apache Tomcat 7.0 7.0.95 → 7.0.109 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 141 CVEs of Apache Tomcat →
Track this CVE