Skip to content
7.1 High

CVE-2025-48912 An authenticated malicious actor using specially crafted requests could bypass row level security configuration by…

Description

An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Superset 4.1 earliest → < 4.1.2 4.1.2

References

Timeline

  1. Published
  2. Last modified
The 65 CVEs of Apache Superset →
Track this CVE