Skip to content
Not rated

CVE-2025-47410 Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could…

Description

Apache Geode is vulnerable to CSRF attacks through GET requests to the Management and Monitoring REST API that could allow an attacker who has tricked a user into giving up their Geode session credentials to submit malicious commands on the target system on behalf of the authenticated user. This issue affects Apache Geode: versions 1.10 through 1.15.1 Users are recommended to upgrade to version 1.15.2, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Geode 1.10 1.10.0 → < 1.15.2 1.15.2

References

Timeline

  1. Published
  2. Last modified
The 18 CVEs of Apache Geode →
Track this CVE