Skip to content
Not rated

CVE-2025-24860 Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they…

Description

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Cassandra 5.0 5.0.0 → 5.0.2 No fix stated
Apache Cassandra 4.1 4.1.0 → 4.1.7 No fix stated
Apache Cassandra 4.0 4.0.0 → 4.0.15 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 10 CVEs of Apache Cassandra →
Track this CVE