Skip to content
2.1 Low

CVE-2025-24859 A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not…

Description

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

Affected products and versions

Product Affected versions Fixed in
Apache Roller 1.0 1.0.0 → < 6.1.5 6.1.5

References

Timeline

  1. Published
  2. Last modified
The 24 CVEs of Apache Roller →
Track this CVE