7.5
High
CVE-2025-11234 Qemu-kvm: vnc websocket handshake use-after-free
Description
A flaw was found in QEMU. If the QIOChannelWebsock object is freed while it is waiting to complete a handshake, a GSource is leaked. This can lead to the callback firing later on and triggering a use-after-free in the use of the channel. This can be abused by a malicious client with network access to the VNC WebSocket port to cause a denial of service during the WebSocket handshake prior to the VNC client authentication.
CVSS 3.1 detail
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitable remotely over the network, without an account and without any user action; an attacker can seriously compromise confidentiality, integrity or availability.
- Attack vector
- Network
- Attack complexity
- Low
- Privileges required
- None
- Interaction
- None
- Scope
- Unchanged
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Affected products and versions
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat Enterprise Linux 9.4 Extended Update Support | Versions not published | |
| Red Hat Enterprise Linux 10 | Versions not published | |
| Red Hat Enterprise Linux 6 | Versions not published | |
| Red Hat Enterprise Linux 7 | Versions not published | |
| Red Hat Enterprise Linux 8 8100020251202222937.489197 | earliest → < 8100020251202222937.489197e6 | 8100020251202222937.489197e6 |
| Red Hat Enterprise Linux 9 | Versions not published | |
| Red Hat OpenShift Container Platform 4 | Versions not published | |
| Red Hat OpenShift Container Platform 4.16 416.94 | earliest → < 416.94.202601071926-0 | 416.94.202601071926-0 |
| Red Hat OpenShift Container Platform 4.18 418.94 | earliest → < 418.94.202601071817-0 | 418.94.202601071817-0 |
Show the 8 other branches Hide the 8 other branches
| Product | Affected versions | Fixed in |
|---|---|---|
| Red Hat OpenShift Container Platform 4.17 417.94 | earliest → < 417.94.202601120213-0 | 417.94.202601120213-0 |
| Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions | Versions not published | |
| Red Hat Enterprise Linux 9.0 Update Services for SAP Solutions | Versions not published | |
| Red Hat OpenShift Container Platform 4.12 412.86 | earliest → < 412.86.202608241157-0 | 412.86.202608241157-0 |
| Red Hat Enterprise Linux 8.8 Telecommunications Update Service 8080020260910092120.63 | earliest → < 8080020260910092120.63b34585 | 8080020260910092120.63b34585 |
| Red Hat Enterprise Linux 8.8 Update Services for SAP Solutions 8080020260910092120.63 | earliest → < 8080020260910092120.63b34585 | 8080020260910092120.63b34585 |
| Red Hat Enterprise Linux 8.4 Advanced Mission Critical Update Support 8040020260916092751.522 | earliest → < 8040020260916092751.522a0ee4 | 8040020260916092751.522a0ee4 |
| Red Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-On 8040020260916092751.522 | earliest → < 8040020260916092751.522a0ee4 | 8040020260916092751.522a0ee4 |
References
- RHSA-2025:23228 access.redhat.com
- RHSA-2026:0326 access.redhat.com
- RHSA-2026:0332 access.redhat.com
- RHSA-2026:0702 access.redhat.com
- RHSA-2026:1831 access.redhat.com
- RHSA-2026:18772 access.redhat.com
- RHSA-2026:22147 access.redhat.com
- RHSA-2026:3077 access.redhat.com
- RHSA-2026:3165 access.redhat.com
- RHSA-2026:5578 access.redhat.com
- RHSA-2026:59831 access.redhat.com
- RHSA-2026:68513 access.redhat.com
- RHSA-2026:69131 access.redhat.com
- access.redhat.com access.redhat.com
- RHBZ#2401209 bugzilla.redhat.com
Timeline
- Published
- Last modified
Other CVEs of Red Hat Enterprise Linux 9.4 Extended Update Support
The 297 CVEs of Red Hat Enterprise Linux 9.4 Extended Update Support →
CVE-2026-46300
Linux Kernel Missing Initialization of a Variable Vulnerability
7.8
High
CVE-2026-43503
In the Linux kernel, the following vulnerability has been resolved: net: skbuff: propagate shared-frag marker through…
8.8
High
CVE-2026-46333
In the Linux kernel, the following vulnerability has been resolved: ptrace: slightly saner 'get_dumpable()' logic The…
7.1
High
CVE-2026-42945
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module
8.1
High