Skip to content
6.4 Medium

CVE-2024-8433 The Easy Mega Menu Plugin for WordPress – ThemeHunk plugin for WordPress is vulnerable to Stored Cross-Site Scripting…

Description

The Easy Mega Menu Plugin for WordPress – ThemeHunk plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘themehunk_megamenu_bg_image' parameter in all versions up to, and including, 1.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Please note that this was partially fixed in 1.1.0 due to the missing authorization protection that was added.

Affected products and versions

Product Affected versions Fixed in
Easy Mega Menu Plugin for WordPress – ThemeHunk 1.1 earliest → 1.1.0 No fix stated
Easy Mega Menu for WordPress – ThemeHunk 1.1 earliest → 1.1.0 No fix stated
The 2 CVEs of Easy Mega Menu Plugin for WordPress – ThemeHunk →
Track this CVE