Skip to content
Not rated

CVE-2024-46544 Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared…

Description

Incorrect Default Permissions vulnerability in Apache Tomcat Connectors allows local users to view and modify shared memory containing mod_jk configuration which may lead to information disclosure and/or denial of service. This issue affects Apache Tomcat Connectors: from 1.2.9-beta through 1.2.49. Only mod_jk on Unix like systems is affected. Neither the ISAPI redirector nor mod_jk on Windows is affected. Users are recommended to upgrade to version 1.2.50, which fixes the issue.

Affected products and versions

Product Affected versions Fixed in
Apache Tomcat Connectors 1.2 1.2.9-beta → 1.2.49 No fix stated

References

Timeline

  1. Published
  2. Last modified
The 4 CVEs of Apache Tomcat Connectors →
Track this CVE